To enter archcon confirm that:

a) Flash-Plugin is installed

b) Javascript is enabled

This site requires Internet Explorer 4.x or Nescape 4.x

If you have trouble check out our technical guide "how to enter archcon"


contact archcon: info@archcon.de